以下は、サーバーにCS.Cartをインストールする前に確認しておくべき項目です。

  1. Webサーバーがインストール要件を最低限満たしていること。
  2. シェルまたはFTP経由でWebサーバにアクセスできること。
  3. MySQLデータベースに接続出来ること。またインストールに必要なデータベースを作成していること。

インストールの最低要件(コア)

  • PHP version 5.3 to 5.4;
  • MySQL version 4.1 またはそれ以降 (MySQLi または pdo_mysql をサポートしていること)
注意

CS.Cartが正しく動作するために
MySQLi または pdo_mysqlのサポートが必須となります。

その他の要件

  • safe_mode が無効であること
  • GD library がインストールされていること
  • cURL support が有効であること。
    このPHPエクステンションは、いくつかの支払い方法やリアルタイムの配送料金計算などに必要です。
  • file_uploads が有効であること;
  • .htaccess が以下のディレクティヴをサポートしていること。
    allowed: DirectoryIndexDenyAllowOptions,OrderAddHandler,
    RewriteEngineRewriteBaseRewriteCond and RewriteRule;